Skip to content

Commit

Permalink
x11-wm/hyprland: downgrade to 0.41.2 due to broken runtime
Browse files Browse the repository at this point in the history
Need help with hyprwm/Hyprland#6842

This reverts commit 7e5a449.
  • Loading branch information
jbeich authored and nanorkyo committed Aug 10, 2024
1 parent e759019 commit c04b282
Show file tree
Hide file tree
Showing 5 changed files with 59 additions and 26 deletions.
11 changes: 6 additions & 5 deletions x11-wm/hyprland/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,7 @@
PORTNAME= hyprland
DISTVERSIONPREFIX= v
DISTVERSION= 0.42.0
DISTVERSION= 0.41.2
PORTREVISION= 1
CATEGORIES= x11-wm wayland

MAINTAINER= [email protected]
Expand All @@ -19,24 +20,24 @@ LIB_DEPENDS= libhyprlang.so:devel/hyprlang \
libdrm.so:graphics/libdrm \
libwayland-server.so:graphics/wayland \
libuuid.so:misc/e2fsprogs-libuuid \
libaquamarine.so:x11-toolkits/aquamarine \
libwlroots-${PORTNAME}.so:x11-toolkits/wlroots-${PORTNAME} \
libhyprcursor.so:x11/hyprcursor \
libinput.so:x11/libinput \
libxkbcommon.so:x11/libxkbcommon

USES= cmake:indirect compiler:c++11-lib gl gnome meson pkgconfig xorg
USE_GITHUB= yes
USE_GL= egl gbm opengl
USE_GL= egl opengl
USE_GNOME= cairo pango
USE_XORG= pixman xcursor
USE_XORG= pixman
GH_ACCOUNT= hyprwm
GH_PROJECT= Hyprland
GH_TUPLE= hyprwm:hyprland-protocols:v0.2-5-ge06482e:hyprland_protocols/subprojects/hyprland-protocols \
canihavesomecoffee:udis86:1.7.2-186-g5336633:udis86/subprojects/udis86
MESON_ARGS= -Dsystemd=disabled

# Generated by "make update-hash" for commit_pins in hyprpm.toml
GH_HASH= 9a09eac79b85c846e3a865a9078a3f8ff65a9259
GH_HASH= 918d8340afd652b011b937d29d5eea0be08467f5

# XXX Drop after FreeBSD 14.0 EOL around 2024-10-01
.if exists(/usr/lib/libc++.so) && !exists(/usr/include/c++/v1/__format/write_escaped.h)
Expand Down
6 changes: 3 additions & 3 deletions x11-wm/hyprland/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
TIMESTAMP = 1723058230
SHA256 (hyprwm-Hyprland-v0.42.0_GH0.tar.gz) = 70f67725c7a1745d0287a954790f323e75519a1a188a3bf4b21fd968be3f5e4a
SIZE (hyprwm-Hyprland-v0.42.0_GH0.tar.gz) = 48049320
TIMESTAMP = 1719317162
SHA256 (hyprwm-Hyprland-v0.41.2_GH0.tar.gz) = bba2cf0ec1451eb86761e88cbc3d00e9acbfa1ea732d6ed103a2186400e93dc9
SIZE (hyprwm-Hyprland-v0.41.2_GH0.tar.gz) = 48025946
SHA256 (hyprwm-hyprland-protocols-v0.2-5-ge06482e_GH0.tar.gz) = 05055f71e1f08496320bab54daa190f2fafec1a0e019af244edf1d37cdbf9b8a
SIZE (hyprwm-hyprland-protocols-v0.2-5-ge06482e_GH0.tar.gz) = 7424
SHA256 (canihavesomecoffee-udis86-1.7.2-186-g5336633_GH0.tar.gz) = 69aff959179ff6247b375b92e797221dbd8e078eabbf1366280b0532617e7fb8
Expand Down
14 changes: 0 additions & 14 deletions x11-wm/hyprland/files/patch-hyprpm

This file was deleted.

46 changes: 46 additions & 0 deletions x11-wm/hyprland/files/patch-system-wlroots
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
Allow system wlroots to reduce maintenance (wlroots has tons of options)

--- meson.build.orig 2024-04-14 18:48:28 UTC
+++ meson.build
@@ -33,8 +33,8 @@ endif
add_project_arguments('-DHAS_EXECINFO', language: 'cpp')
endif

-wlroots = subproject('wlroots-hyprland', default_options: ['examples=false', 'renderers=gles2'])
-have_xwlr = wlroots.get_variable('features').get('xwayland')
+wlroots = dependency('wlroots-hyprland', default_options: ['examples=false', 'renderers=gles2'])
+have_xwlr = wlroots.get_variable(pkgconfig: 'have_xwayland', internal: 'have_xwayland') == 'true'
xcb_dep = dependency('xcb', required: get_option('xwayland'))

cmake = import('cmake')
@@ -89,5 +89,6 @@ import('pkgconfig').generate(
url: 'https://github.com/hyprwm/Hyprland',
description: 'Hyprland header files',
install_dir: pkg_install_dir,
- subdirs: ['', 'hyprland/protocols', 'hyprland/wlroots'],
+ subdirs: ['', 'hyprland/protocols'],
+ requires_private: wlroots,
)
--- src/meson.build.orig 2024-04-14 18:48:28 UTC
+++ src/meson.build
@@ -9,7 +9,7 @@ executable('Hyprland', src,
server_protos,
dependency('wayland-server'),
dependency('wayland-client'),
- wlroots.get_variable('wlroots'),
+ wlroots,
dependency('cairo'),
dependency('hyprcursor'),
dependency('hyprlang', version: '>= 0.3.2'),
--- hyprpm/src/core/PluginManager.cpp.orig 2024-04-14 18:48:28 UTC
+++ hyprpm/src/core/PluginManager.cpp
@@ -316,9 +316,6 @@ eHeadersErrors CPluginManager::headersValid() {
eHeadersErrors CPluginManager::headersValid() {
const auto HLVER = getHyprlandVersion();

- if (!std::filesystem::exists(DataState::getHeadersPath() + "/share/pkgconfig/hyprland.pc"))
- return HEADERS_MISSING;
-
// find headers commit
std::string cmd = std::format("PKG_CONFIG_PATH=\"{}/share/pkgconfig\" pkgconf --cflags --keep-system-cflags hyprland", DataState::getHeadersPath());
auto headers = execAndGet(cmd.c_str());
8 changes: 4 additions & 4 deletions x11-wm/hyprland/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -5,10 +5,10 @@ share/bash-completion/completions/hyprctl
share/bash-completion/completions/hyprpm
share/fish/vendor_completions.d/hyprctl.fish
share/fish/vendor_completions.d/hyprpm.fish
share/hypr/hyprland.conf
share/hypr/wall0.png
share/hypr/wall1.png
share/hypr/wall2.png
%%DATADIR%%/hyprland.conf
%%DATADIR%%/wall0.png
%%DATADIR%%/wall1.png
%%DATADIR%%/wall2.png
share/man/man1/Hyprland.1.gz
share/man/man1/hyprctl.1.gz
share/pkgconfig/hyprland.pc
Expand Down

0 comments on commit c04b282

Please sign in to comment.